Supported Firmware Versions:        


If you are receiving a firmware update notification it is most likely, because your UAV's firmware doesn't match up with the supported firmware. You may have to upgrade or downgrade your firmware for best performance in the PrecisionFlight app.


Listed below are the supported firmware versions of each UAV. 


- Matrice 200: 01.00.00.0000

- Phantom 4 Advanced: 01.00.0128

- Inspire 2: 1.0.0330

- Phantom 4 Pro: 01.04.0602

- Mavic Pro: 01.03.0900

- Matrice 600 Pro: 1.0.1.20

- Matrice 600, RTK and Ronin MX: 1.0.1.20         

- Phantom 4: 1.2.602

- Inspire 1: 1.10.1.40

- Inspire 1 Pro (X5 camera): 1.10.1.40

- Inspire 1 RAW (X5R camera): 1.10.1.40         

- Phantom 3 Professional & Advanced: 1.10.90        

- Phantom 3 Standard: 1.8.10

- Phantom 3 4K: 1.5.40

- Matrice 100: 1.3.1.0